On Friday, June 15, 07, I patched the global zone on a machine with 2 local 
zones. The global zone has 4 file systems connected (but not mounted) from a 
3320 storage array. Using lofiadm -a, i created 4 devices which I imported to 
the local zones - 2 to each zone. I then mounted the 4 file systems.

After patching and rebooting the global zone, the imported lofi devices would 
not mount. The error messages was mount: /dev/lofi/1 is not this fstype. The 
same error held for the other 3 devices.

ls -l /dev/*lofi/* in the global zone showed the devices present. I reran the 
lofiadm -a command and the devices were recreated, starting, again, with 
/dev/lofi/1 and not 5 which I expected. I was not specifying the disk device 
(c5todos0) and lofiadm creates them sequentially.

When all lofi devices were recreated, I ran mount -a in the local zones and 
voila, the file systems mounted. I suspect a bug in one of the applied patches. 
I have submitted a bug report (my case # 4106) but I'm hoping someone has seen 
this and can lead me to the fix (short of running lofiadm -a every time the 
global zone boots).

Thanks in advance - Ron
 
 
This message posted from opensolaris.org
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to