On Tue, Feb 2, 2010 at 4:10 PM, Gael <gael.marti...@gmail.com> wrote:

> I ran a few test upgrades moving zones from a T5220 u6 system to a u8
> system patched with 119254-72 and I keep observing the following packages
> missing into the end result zone..
> I'm really concerned by the pkg/patch tools packages missing ...  I have
> tried to also patch the source system before detaching the zone without
> success ... Here is a diff of the packages missing in the zone but present
> in the GZ.
> SUNWgccruntime                                                  <
> SUNWinstall-patch-utils-root                                    <
> SUNWntp4r                                                       <
> SUNWntp4u                                                       <
> SUNWpkgcmdsr                                                    <
> SUNWpkgcmdsu                                                    <
> SUNWppror                                                       <
> SUNWpprou                                                       <
> SUNWproduct-registry-root                                       <
> SUNWs8brandr                                                    <
> SUNWs8brandu                                                    <
> SUNWstosreg                                                     <
> SUNWswmt                                                        <
> SUNWwsr2                                                        <
> Is that a known issue ?
> Regards
> --
> Gael Martinez

I reloaded the landing-zone machine with a vanilla U8 image (basic
installation, all packages, no patches), and reused the same ufsdump
file containing the zone. zoneadm update -u with that version did install
the pkg related packages...

labs9006.uhc.com:/zones #zoneadm -z apsz0224 attach -u
zoneadm: zone 'apsz0224': WARNING: pools facility not active; zone will not
be bound to pool 'fss_default_pool'.
zoneadm: zone 'apsz0224': WARNING: pools facility not active; zone will not
be bound to pool 'fss_default_pool'.
Getting the list of files to remove
Removing 2520 files
Remove 15 of 15 packages
Installing 25271 files
Add 454 of 454 packages
Installation of these packages generated warnings: SUNWcsr SUNWgssc
SUNWinstall-patch-utils-root SUNWkrbr SUNWmconr SUNWntpr SUNWpcr SUNWppror
SUNWpsr SUNWsacom SUNWwbcor SUNWxwplr VRTSodm
Updating editable files
The file </var/sadm/system/logs/update_log> within the zone contains a log
of the zone update.

labs9006.uhc.com:/zones #zlogin apsz0224 pkginfo | grep SUNWpkgcmd
system      SUNWpkgcmdsr                    SVr4 package commands (root)
system      SUNWpkgcmdsu                    SVr4 packaging commands (usr)
labs9006.uhc.com:/zones #

The same issue was confirmed when testing S10 U4 to U8 upgrades...
Will continue toying around tomorrow and will open a case if I don't hear
anything from this list.

Gael Martinez
zones-discuss mailing list

Reply via email to