On Thu, 04 Feb 2010 01:11:19 +0100, Ted Ward <thomas.w...@sun.com> wrote:

> I am trying to migrate a zone on OpenSolaris from one identical system
> to another.  It's going from x86 to sparc, but even when going from x86
> to x86 I get the same error.  Here's the build of both systems
> SunOS hostname 5.11 snv_111b i86pc i386 i86pc Solaris  (source system)
> SunOS hostname 5.11 snv_111b sun4u sparc SUNW,Sun-Blade-100 Solaris
> (target system)
> After creating the zone on zfs per expectations, I detach it it and get
> the typical directory you would expect:
> # ls
> SUNWdetached.xml  dev  root
> I then run the following command to migrate the zone:
> zfs send rpool/tedz...@migrate | ssh u...@hostname pfexec /usr/sbin/zfs
> receive -F rpool/tedz...@migrate
> Everything looks good at that point.  The zfs file system is mounted at
> rpool/tedzone automatically, and so I create a zone configuration to
> match that.  However, when I run the attach I get the following error
> message:
> zoneadm -z tedzone attach
> cannot open 'rpool/tedzone/ROOT': dataset does not exist
> ERROR: The -a, -d or -r option is required when there is no active root
> dataset
> The funny thing here is that the zfs list on the source system doesn't
> mention this zfs file system:
> rpool/tedzone              242M  64.1G  22.5K  /tedzone
> rpool/tedzone/ROOT         242M  64.1G    19K  legacy
> rpool/tedzone/ROOT/zbe     242M  64.1G   242M  /tedzone/root

so if the above output is from the source system it does list
the 'rpool/tedzone/ROOT ' dataset, right ? I'm not sure why you claim
it does not ?

is the above zfs list from the source system before doing the zoneadm detach or 
after ?

can you show the zfs list output from the target system after the zfs receive 
zoneadm attach ?

I believe in the build 111b (2009.06) you are using, when a zone is 
the corresponding zfs datasets where not visible in the GZ, and we later 
changed that
(i'm not sure if that was before or after 111b/2009.06).

zones-discuss mailing list

Reply via email to