On 02/ 3/10 04:11 PM, Ted Ward wrote:
Hello all.

I am trying to migrate a zone on OpenSolaris from one identical system to another. It's going from x86 to sparc, but even when going from x86 to x86 I get the same error. Here's the build of both systems

SunOS hostname 5.11 snv_111b i86pc i386 i86pc Solaris  (source system)
SunOS hostname 5.11 snv_111b sun4u sparc SUNW,Sun-Blade-100 Solaris (target system)

After creating the zone on zfs per expectations, I detach it it and get the typical directory you would expect:

# ls
SUNWdetached.xml  dev  root

I then run the following command to migrate the zone:

zfs send rpool/tedz...@migrate | ssh u...@hostname pfexec /usr/sbin/zfs receive -F rpool/tedz...@migrate

Everything looks good at that point. The zfs file system is mounted at rpool/tedzone automatically, and so I create a zone configuration to match that. However, when I run the attach I get the following error message:

zoneadm -z tedzone attach
cannot open 'rpool/tedzone/ROOT': dataset does not exist
ERROR: The -a, -d or -r option is required when there is no active root dataset

The funny thing here is that the zfs list on the source system doesn't mention this zfs file system:

rpool/tedzone              242M  64.1G  22.5K  /tedzone
rpool/tedzone/ROOT         242M  64.1G    19K  legacy
rpool/tedzone/ROOT/zbe     242M  64.1G   242M  /tedzone/root

Are we looking at a bug here?


Hi Ted,

First, I don't think that we support sparc <--> x86 zone migrations. (Someone please correct me if I'm wrong.)

Second, did you create recursive snapshots of tedzone's datasets and send each snapshot to the destination system? Try the following after you detach tedzone:

---8<---
# zfs snapshot -r rpool/tedz...@migrate
---8<---

Then send each dataset snapshot to the destination system:

---8<---
# zfs send rpool/tedz...@migrate | ssh u...@hostname pfexec /usr/sbin/zfs receive -F rpool/tedz...@migrate # zfs send rpool/tedzone/r...@migrate | ssh u...@hostname pfexec /usr/sbin/zfs receive -F rpool/tedzone/r...@migrate # zfs send rpool/tedzone/ROOT/z...@migrate | ssh u...@hostname pfexec /usr/sbin/zfs receive -F rpool/tedzone/ROOT/z...@migrate
---8<---

Then attach the zone on the destination system.

BTW, as Frank mentioned, your output shows that the source system's tedzone contained the ROOT and ROOT/zbe filesystems.

Hope that helps,
Jordan
_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to