I'm on ubuntu (hardy heron) and they work. Our CI machine has intermittent failures (solaris x86):

there's some timing issue, what you're seeing is probably related to:

Frankly tests and docs are both areas that ZooKeeper could use _a lot_ of care and feeding. Tests in particular could use some refactoring and a better implementation for launching/testing/stopping client/server tests.

As you're able to reproduce the issue reliably would you like to take on 61? Feel free to assign to yourself if so.



James Strachan wrote:
I've always had some tests failing on most boxes I try; I wasn't sure
if everyone else got those or if they do work on some platforms?

On OS X I get these failures
    [junit] Test org.apache.zookeeper.test.AsyncTest FAILED
    [junit] Test org.apache.zookeeper.test.WatcherFuncTest FAILED

On a linux box (an EC2 box) I get these failures

    [junit] Test org.apache.zookeeper.test.ClientTest FAILED
    [junit] Test org.apache.zookeeper.test.QuorumTest FAILED

Maybe they all work on windows? :)

I tried adding an explicit forkmode="perTest" to the <junit> and I
still get the same results. Can anyone else get the tests to work on
linux or OS X?

Reply via email to