[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-29?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Flavio Paiva Junqueira updated ZOOKEEPER-29:
--------------------------------------------

    Attachment: ZOOKEEPER-29.patch

I made an attempt at making the protocol backward compatible. Basically, a 
FollowerHandler is able to interpret both FOLLOWERINFO message and LASTZXID. If 
it receives a LASTZXID message, it generates a unique id number that does not 
correspond to the server id, but ti doesn't matter if we are using majority 
because for majority we only need to count votes. Of course, if a user tries to 
use hierarchical quorums with servers running older versions, it won't work.   

> Flexible quorums
> ----------------
>
>                 Key: ZOOKEEPER-29
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-29
>             Project: Zookeeper
>          Issue Type: New Feature
>          Components: server
>            Reporter: Patrick Hunt
>            Assignee: Flavio Paiva Junqueira
>             Fix For: 3.2.0
>
>         Attachments: ZOOKEEPER-29.patch, ZOOKEEPER-29.patch, 
> ZOOKEEPER-29.patch, ZOOKEEPER-29.patch, ZOOKEEPER-29.patch, 
> ZOOKEEPER-29.patch, ZOOKEEPER-29.patch, ZOOKEEPER-29.patch, 
> ZOOKEEPER-29.patch, ZOOKEEPER-29.patch
>
>
> Moved from SourceForge to Apache.
> http://sourceforge.net/tracker/index.php?func=detail&aid=1938782&group_id=209147&atid=1008547

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to