[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-908?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Thomas Koch updated ZOOKEEPER-908:
----------------------------------

    Attachment:     (was: ZOOKEEPER-908.patch)

> Remove code duplication and inconsistent naming in ClientCnxn.Packet creation
> -----------------------------------------------------------------------------
>
>                 Key: ZOOKEEPER-908
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-908
>             Project: Zookeeper
>          Issue Type: Sub-task
>          Components: server
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>            Priority: Minor
>             Fix For: 3.4.0
>
>
> rename record -> request (since their is a counterpart record named 
> "response")
> rename header -> requestHeader (to distinguish from responseHeader)
> remove ByteBuffer creation code from primeConnection() method and use the 
> duplicate code in the Packet constructor. Therefor the Bytebuffer bb 
> parameter could also be removed from the constructor's parameters.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to