Thomas Koch updated ZOOKEEPER-908:

    Attachment: ZOOKEEPER-908.patch

new patch against the current Client after ZOOKEEPER-909

There are not new tests in this patch. Please commit it anyway. I'm planning to 
move the Packet class out to a separate file as part of ZOOKEEPER-894. 
Then I'd like to do ZOOKEEPER-878.
After this, it would be the right time to see if the Packet class needs any 

I'd like to collect these low hanging fruits and make the Client java stuff 
more comprehensible before continuing with the Netty stuff in ZOOKEEPER-823

> Remove code duplication and inconsistent naming in ClientCnxn.Packet creation
> -----------------------------------------------------------------------------
>                 Key: ZOOKEEPER-908
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-908
>             Project: Zookeeper
>          Issue Type: Sub-task
>          Components: server
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>            Priority: Minor
>             Fix For: 3.4.0
>         Attachments: ZOOKEEPER-908.patch
> rename record -> request (since their is a counterpart record named 
> "response")
> rename header -> requestHeader (to distinguish from responseHeader)
> remove ByteBuffer creation code from primeConnection() method and use the 
> duplicate code in the Packet constructor. Therefor the Bytebuffer bb 
> parameter could also be removed from the constructor's parameters.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to