Btw, the docs for a particular version of ZK are always included in the release (under docs toplevel directory). The docs on the apache site are always for the latest stable release (currently 3.2.1). That's why you saw the discrepancy.


Something Something wrote:
Switched to 3.2.1.  Much better.  Got a command prompt.  Thank you both.

On Wed, Dec 9, 2009 at 10:09 AM, Henry Robinson <> wrote:

The 3.2.1 command line is a lot nicer (has an actual prompt, tab
auto-completion, shows your connection status etc) - if you can upgrade to
3.2.1 which is a good deal more modern, I would recommend it. If I recall
correctly, there was no prompt in 3.1.1...


On Wed, Dec 9, 2009 at 9:36 AM, Something Something <> wrote:

Without -server made some progress, but don't see a command prompt.
Shouldn't I see one?

This is what I see:
2009-12-09 17:27:56,709 - INFO  [main:zookee...@341] - Initiating client
connection, host= sessionTimeout=5000
2009-12-09 17:27:56,710 - INFO  [main:clientc...@91] -
zookeeper.disableAutoWatchReset is false
2009-12-09 17:27:56,792 - INFO
- Attempting connection to server /
2009-12-09 17:27:56,802 - INFO
- Priming connection to java.nio.channels.SocketChannel[connected local=/ remote=/]
2009-12-09 17:27:56,806 - INFO
- Server connection successful
WatchedEvent: Server state change. New state: SyncConnected

Should I just use 3.2.1 version?

On Wed, Dec 9, 2009 at 9:20 AM, Mahadev Konar <>

 Can you try this?


The -server command was added later as far as I remember.


On 12/9/09 9:05 AM, "Something Something" <>

I am trying to start ZooKeeper on an EC2 instance.  Here's what I
1)  Downloaded & Unpacked ZooKeeper 3.1.1 on EC2 instance.
2)  cp /conf/zoo_sample.cfg /conf/zoo.cfg
3)  Changed the dataDir path to point to my EBS volume.
4)  In one command window, ran /bin/ start
(The last message I see is... "Snapshotting: 0)

5)  Opened another command window, and ran jps
(This shows a new process called, QuorumPeerMain.  That's the only

6)  As per documentation, tried

bin/ -server

(This gives me IOException: USAGE)

7) So I ran:

bin/ -server ls

Got UnknownHostException: -server

8)  So I tried various ways of specifying IP address in EC2, such as:


None of them worked.  Keep getting UnknownHostException.

What am I doing wrong.  Please help.  Thanks.

Reply via email to