Hi David -

As far as I can tell this was not a deliberate omission - earlier versions
of the package definitely had zkCli bundled with.  Apologies for the
oversight. Can you fix by copying zkCli.sh from a 3.2.* tarball from the
Apache site?

However, these packages are rather old, and we haven't updated them in a
while. In fact, I believe the contrib repo is no longer available. We at
Cloudera will be releasing first-class packages for ZooKeeper with the next
beta release of our distribution, CDH3 Beta 2. For more details see
http://www.cloudera.com/blog/2010/03/cdh3-beta1-now-available/.

cheers,
Henry

On 26 April 2010 14:05, David Rosenstrauch <dar...@darose.net> wrote:

> I installed the zookeeper package (hbase-0.20-zookeeper) from the Cloudera
> CDH contrib repo.  But neither it nor the hbase-0.20 package that it's
> dependent on seem to supply the zkCli command line utility.
>
> Anyone know if this is intentional and/or how to fix?
>
> Thanks,
>
> DR
>



-- 
Henry Robinson
Software Engineer
Cloudera
415-994-6679

Reply via email to