On Mon, Sep 12, 2005 at 02:03:24PM +0200, Jean-Marc Orliaguet wrote:
| Hi Sidnei
| the difference is that portal_catalog is both a tool and a catalog
| instance (with its indexes, records...). Other CMF tools are just tools
| and their path can well be hardcoded in CMF since they provide only
| functionality.

That's not good enough of an argument for me. Are you suggesting that
in some places it's used as 'catalog' and in some places it's used as
'tool'? If that's the case, then we should identify such places and
use different 'tokens' for each use. Eg: 'portal_catalog' and
'portal_catalog_tool' or something.

Still, the place to add indirection would be 'getToolByName'. As Tres
said above, let's not invent another component architecture.

Sidnei da Silva
Enfold Systems, LLC.
Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to