Tres Seaver wrote:
yuppie wrote:
Hi Rocky!


Rocky Burt wrote:
On Sun, 2006-04-06 at 18:12 +0200, yuppie wrote:
Rocky Burt wrote:

What do you all think?  Something we can include in time for CMF1.6.1
beta2 ?
I don't care much about CMF 1.6, but I wonder in which case your patch is useful. Are you suggesting that people write cutting-edge Products-less python packages and add deprecated fti data in those packages to make it available through the deprecated listDefaultTypeInformation method?

All of this work I'm doing is geared towards having Zope 2 developers
write code that is less Zope 2 specific and more python specific.
Nothing about bleeding edge, etc.

In the Zope 2 world I consider that bleeding edge.

And there is going to be large
community of third-party app developers writing products against the
not-yet-released Plone 2.5.  But my feeling was that Plone wsan't the
only product based on CMF1.6 ... if it were then I could provide a
monkey right in plone but this is the absolute wrong approach imho.

I hope neither Plone 2.5 nor CPS 3.4 require oldstyle fti data. CMF 1.6 doesn't. Shipping Products-less python packages without profile based fti data sounds strange to me. And if the reason is that registering profiles doesn't work that should be fixed instead of falling back to oldstyle fti data.

Ultimately Plone needs to get to CMF2 and that will happen with Plone
3.0, but there were simply too many changes in CMF to allow Plone to do
that within the 2.5 timeframe.

Anyhow, I'm trying to make compromises to keep as many people happy as
possible.  Originally I wanted to add this to CMF 1.5.x as well :)

I'll shut up now. I don't use CMF 1.6 and I don't think your code will break CMF 1.6.

I'm pretty sure that Plone is the only major user of CMF 1.6. That release wouldn't even have happened except to help out Plone's release cycle for 2.5 (which, as it turns out, would probably have been releasable against Zope 2.9 / CMF 2.0, but that is a different story).

CPS 3.4 (which is in maintenance mode, 3.4.1 has been tagged) is using CMF 1.6 right now. Except for GenericSetup bugfixes, which we can always provide as monkey-patches from our CPSCompat product, we don't need specific evolutions from CMF 1.6 at the moment. We would only switch for the next maintenance release to CMF 1.6.1 if nothing breaks with it.

CPS 4, scheduled for September, will use CMF 2.0 (and Zope 2.10).

Florent

--
Florent Guillaume, Nuxeo (Paris, France)   Director of R&D
+33 1 40 33 71 59   http://nuxeo.com   [EMAIL PROTECTED]
_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to