Hi Maurits!

Maurits van Rees wrote:
CMF Tests Summarizer, on 2008-02-28:
Summary of messages to the cmf-tests list.
Period Wed Feb 27 12:00:00 2008 UTC to Thu Feb 28 12:00:00 2008 UTC.
There were 9 messages: 9 from CMF Unit Tests.

Test failures

Subject: FAILED (errors=1) : CMF-2.1 Zope-2.11 Python-2.4.4 : Linux
From: CMF Unit Tests
Date: Wed Feb 27 21:37:14 EST 2008
URL: http://mail.zope.org/pipermail/cmf-tests/2008-February/008108.html

I caused this failure.  I thought yuppie fixed it yesterday.

I fixed it in GS trunk, but forgot to backport the fix to the 1.3 branch which is used by CMF 2.1. Can you port it back?

is that I cannot reproduce it: my testing environment apparently
differs from that used in these daily tests.

unittest.TestCase doesn't initialize Zope, ZopeTestCase does. If you run an other ZopeTestCase (or similar) before running your test, Zope is still initialized. So this is a side effect depending on the order in which tests are run. You can run the test file itself (or specific tests using the testrunner) to minimize the side effects.



Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to