I have an instance of a ZClass stored on a Rack.the ZClass contains a 
Folder named displayItemsVisitor. I changed the Folder's View 
permission to from 'View' to 'Manage Application Objects' which is a 
permission defined in my Product. I then gave viewOrder_html, which 
is a DTML Method that calls a method inside this Folder a proxy role 
which has the Manage Application Objects permission. Then I tried to 
view viewOrder_html. I got Unauthorized on access to 

Fine. I already know that ZClass permissions are a mine field, so I 
decided to give it up for now. So I returned everything to normal - 
set the View permission of displayItemsVisitor back to 'View' and 
removed the proxy role from viewOrder_html. When I tried to view 
viewOrder_html, I got the same Unauthorized error.

So, I deleted displayItemsVisitor. Then I created a new one. Still 
Unauthorized. Cache problem? I set the Cache Target Size and Target 
max time to 0 and flushed the cache. Still Unauthorized. 
Interestingly, the cache page shows 1281 objects in the cache even 
after flushing.

My best guess is that there is some cache problem with ZPatterns, 
where it continues to serve cached items and ignores object changes 
and cache flushing. In fact, I'm pretty sure there is a cache problem 
is ZPatterns, because on several occasions in the past ZPatterns 
continued to serve items after I deleted them from the database.

So the question is, what do I do now?

TIA, Itai
Itai Tavor                      -- "Je sautille, donc je suis."    --
[EMAIL PROTECTED]            --               - Kermit the Frog --
--                                                                 --
-- "If you haven't got your health, you haven't got anything"      --

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to