On Sun, Jul 27, 2003 at 01:22:59AM +0200, PieterB wrote:
> Hi,
> I tested todays Zope CVS checkout on Python 2.2.3 on FreeBSD 5.0. I
> noticed the following issues:
> (1) I noticed that the "restart" button is missing on the Control
> Panel. Is this intended behaviour for Zope 2.7? Or did I encounter
> a bug? There is still a Shutdown button, BTW.

You probably started it with 'runzope', which doesnt run the
daemon. You should use 'zopectl start'.

> (2) I also tried to install some products in the INSTANCE_HOME/Products
> directory. There was a README.txt there telling:
>       "Additional products for your Zope instance should be
>       installed in this directory.  A freshly created instance
>       should only contain this README.txt file in this directory."
> I tried adding a product to this directory (Formulator from CVS),
> but it didn't loaded when I restarted the Zope instance (from
> commandline because of (1)). It loads fine if I move it to

I noticed that as well, and I had to modify runzope/zopectl to 'export
INSTANCE_HOME' to make it work. Also, enabling debug mode on zope.conf
doesnt seem to be working, and as there is an instance home setting on
zope.conf, I guess there is some major problem with the scripts right
now that are preventing it from getting the sets from the
configuration file. Other settings like enabling webdav and disabling
ftp work just fine.

Sidnei da Silva <[EMAIL PROTECTED]>
dreamcatching :: making your dreams come true

Disclaimer: "These opinions are my own, though for a small fee they be
yours too."
                -- Dave Haynie

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to