Jim Fulton wrote at 2003-11-22 12:14 -0500: > ... > Also note that I had to get rid of the validateValue call. It's important > that we always pass the name and container to code that needs to get roles.
We need "name" and "container" only for objects that do not have their own "__roles__" attribute. This essientially means for the newly implemented methods. But, for bound methods, we can determine name and container from the objects. I would therefore keep "validateValue" and try to determine container and name. -- Dieter _______________________________________________ Zope-Dev maillist - [EMAIL PROTECTED] http://mail.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce http://mail.zope.org/mailman/listinfo/zope )
