The default Zope setup has two databases: the main database and the
session database.  So it's not completely nonsensical for any
default-configured Zope to raise the error (although I have no idea how
this error is occurring).  It might be worthwhile to specify a main
database explicitly in zope.conf.  This will prevent the default
database setup from being invoked and then you will be sure that you
only have one database connection.

On Wed, 2003-12-10 at 11:19, Jeremy Hylton wrote:
> On Wed, 2003-12-10 at 11:14, Sidnei da Silva wrote:
> > Has anyone run into this one?
> [ traceback snipped ]
> > ZODB.POSException.InvalidObjectReference: Attempt to store an object
> > from a foreign database connection
> 
> Do you actually have more than one database connection?  In other words,
> is the error totally nonsensical or could the bug be that something is
> getting stored in a foreign database connection?
> 
> Jeremy
> 
> 
> 
> _______________________________________________
> Zope-Dev maillist  -  [EMAIL PROTECTED]
> http://mail.zope.org/mailman/listinfo/zope-dev
> **  No cross posts or HTML encoding!  **
> (Related lists - 
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope )


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to