Hi there,
I have a DCWorkflow (running under plone 1.04) that has bean doing fine now for a year 
or so.
Now under 2.7 I get the following traceback:

thanks for any help
Robert

Traceback (innermost last):
  Module ZPublisher.Publish, line 100, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 40, in call_object
  Module Products.CMFPlone.FormTool, line 235, in __call__
  Module Products.CMFPlone.NavigationTool, line 98, in getNextObject
  Module Products.CMFPlone.NavigationTool, line 289, in _getScript
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 40, in call_object
  Module Products.CMFCore.FSPythonScript, line 92, in __call__
  Module Shared.DC.Scripts.Bindings, line 261, in __call__
  Module Shared.DC.Scripts.Bindings, line 292, in _bindAndExec
  Module Products.CMFCore.FSPythonScript, line 126, in _exec
   - __traceback_info__: ({'traverse_subpath': [], 'container': <PloneSite instance at 
415a00b0>, 'context': <Image at /intranet/intranetFHA/Members/sorg/Beispiel.jpg>, 
'script': <FSPythonScript at /intranet/intranetFHA/object_status_modify used for 
/intranet/intranetFHA/Members/sorg/Beispiel.jpg>}, ('publishCompany', '                
', '', '', '', None, None, None, []), {}, (None, '', None, None, '', None, None, None, 
[]))
  Module None, line 61, in object_status_modify
  Module Products.CMFPlone.WorkflowTool, line 37, in doActionFor
  Module Products.CMFCore.WorkflowTool, line 309, in doActionFor
  Module Products.CMFCore.WorkflowTool, line 624, in _invokeWithNotification
  Module Products.DCWorkflow.DCWorkflow, line 275, in doActionFor
  Module Products.DCWorkflow.DCWorkflow, line 440, in _changeStateOf
  Module Products.DCWorkflow.DCWorkflow, line 489, in _executeTransition
  Module Shared.DC.Scripts.Bindings, line 261, in __call__
  Module Shared.DC.Scripts.Bindings, line 290, in _bindAndExec
  Module Shared.DC.Scripts.Bindings, line 1, in ?
  Module Shared.DC.Scripts.Bindings, line 224, in _getContext
  Module AccessControl.ImplPython, line 398, in validate
  Module Products.VerboseSecurity.VerboseSecurityPolicy, line 272, in validate
Unauthorized: Your user account does not have the required permission.  Access to '' 
of (DCWorkflowDefinition instance at 42005170) denied. Your user account, sorg, exists 
at /intranet/intranetFHA/acl_users. Access requires one of the following roles: 
['Manager']. Your roles in this context are ['Authenticated', 'Mitarbeiter'].


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to