I've been experiencing the most peculiar core dump under Zope 2.7. It's on a web application we only decided to revive late last week, so it was never tested under earlier beta/RC conditions.

The core dump occurs when visiting manage_main on a particular folder. The contents of this folder are basically just Python Scripts, Page Templates, and a few DTML Methods (including standard_error_message).

I can get manage_main to render in zopectl debug (using Testing.make_request to make enough of a REQUEST object for it to render with). And I can read everything in that particular folder with zopectl debug. I used this to experiment with moving items around between folders - including moving all of the templates/scripts into their own folder outside of the web application. It still core dumps. At one point, I thought I had narrowed it down to a particular template (although the reasons for why it would be this template elude me) by doing some interactive Python work [I had written some helper 'move_object' and 'copy_object' functions a while back, and used them to move items between a pair of folders and then seeing which one Zope would crash on].

I got the contents of the template out using ``zopectl debug``, and recreated the template by hand, now that I could actually get into the target folder. It worked for a brief moment, but so did the source folder, which now had this one particular template remaining.

I tried various imports and exports of the web application, including using one that was known to still be working off of a production server (Zope 2.6.1, Python 2.1). I even tried copying the contents (individually) of the folder - completely removing them from original context. It still core dumps. (Before I tried imports and exports, it was running in a Data.fs that had been copied from a Zope 2.6.1 instance to 2.7. Python Scripts were recompiled)

Finally, I thought it might be a Python 2.3.3/FreeBSD issue (like there were issues with default stack size on Python 2.1.x and FreeBSD). This Python 2.3.3 had been built from source just last week, on the day I installed Zope 2.7 final on our development server. So I downloaded Zope 2.6.4 and ran that with Python 2.3.3, importing the problematic export. I could list the contents of this particular folder just fine. The import had Python 2.1 compiled scripts, so I recompiled them and exported it again just to see if that was causing strange issues - but when brought into Zope 2.7, the core dump still happens.

The folder in question is not terribly large - when I extracted the scripts/templates manually into a new folder, I think it has about 41 items in it.

What should I do next? Should I familiarize myself with gdb and inspect the core? What are some things I could look for if that's the next step?

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to