Hi Steve,

Thanks for the error report... this is odd.  Could you ship me your
Sessions.fs file (or whatever file you chose to use for the FileStorage
to keep session data)?

- C


On Wed, 2004-06-02 at 15:39, Steve Jibson wrote:
> It seems that there may still be some strangeness with Transience. 
> We're running Zope-2.7.1b1 (Python 2.3.3, Fedora Core 1) and after using 
> the system for a day or two, it got the following error on a page that 
> accesses the SESSION:
> 
>    Traceback (innermost last):
>      Module ZPublisher.Publish, line 101, in publish
>      Module ZPublisher.mapply, line 88, in mapply
>      Module ZPublisher.Publish, line 39, in call_object
>      Module OFS.DTMLDocument, line 128, in __call__
>       - <DTMLDocument instance at 9e684350>
>       -URL: http://george/login/root/ChooseAccount/chooseAccount/manage_main
>       - Physical Path: /login/root/ChooseAccount/chooseAccount
>      Module DocumentTemplate.DT_String, line 474, in __call__
>      Module DocumentTemplate.DT_With, line 76, in render
>      Module DocumentTemplate.DT_In, line 703, in renderwob
>      Module DocumentTemplate.DT_Let, line 76, in render
>      Module DocumentTemplate.DT_Util, line 198, in eval
>       - __traceback_info__: value
>      Module <string>, line 1, in <expression>
>    NameError: name 'SESSION' is not defined
> 
> 
> It doesn't appear to be a problem accessing a variable in the SESSION, 
> but finding "SESSION" itself.
> 
> So, I hook-up to the ZMI and click on *temp_folder*, then click on            
> *session_data (Session Data Container)* and I get the following error:
> 
>    Traceback (innermost last):
>      Module ZPublisher.Publish, line 101, in publish
>      Module ZPublisher.mapply, line 88, in mapply
>      Module ZPublisher.Publish, line 39, in call_object
>      Module App.special_dtml, line 62, in __call__
>      Module DocumentTemplate.DT_String, line 474, in __call__
>      Module Products.Transience.Transience, line 709, in nudge
>      Module Products.Transience.Transience, line 555, in _gc
>    RuntimeError: the bucket being iterated changed size
> 
> 
> The same thing happened yesterday and re-starting Zope seemed to get 
> things working again.  After the problem yesterday, I changed my temp 
> database to use filestorage to see if that would help.  No luck, the 
> problem showed up again today.
> 
> I have not restarted Zope again today, so my system is still in the 
> "screwed-up" state.  Chris, if you'd like, I can probably get you access 
> to the system if there is anything to be learned from it in its current 
> state.
> 
> Thanks,
> 
> Steve
> 
> _______________________________________________
> Zope-Dev maillist  -  [EMAIL PROTECTED]
> http://mail.zope.org/mailman/listinfo/zope-dev
> **  No cross posts or HTML encoding!  **
> (Related lists - 
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope )


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to