chrism wrote:

FWIW, the fact that you get the error at that point means that
cDocumentTemplate can't be imported (it's using pDocumentTemplate, which
nobody uses since it's a "fallback").  This is probably the root of the
problem.  I suspect pDocumentTemplate would give the same error on any
platform.  I would start investigating why cDocumentTemplate fails to

Doh! I bet it is because I have copied over the install from one of our other servers, and the C components will have been compiled with py2.3, and hence probably not imported successfully into py2.4.

Before I realised this I did a fresh install, using Zope 2.7.3b2 and py2.4a3 and after I got all the modules I needed recompiled for py2.4 (PIL, GD, 4Suite, etc.) I started Zope and is still crashed with a Bus Error. Which was what I was getting with py2.3 on FreeBSD/AMD64. So it looks like it just gets a little further with py2.4, but there are still problems. I'll try and get the recursion limit a bit lower and see if that helps it get through.


Matt Hamilton                                       [EMAIL PROTECTED]
Netsight Internet Solutions, Ltd.        Business Vision on the Internet                             +44 (0)117 9090901
Web Design | Zope/Plone Development & Consulting | Co-location | Hosting

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to