>> I'm copying Fred because he may remember more about this than I do.
>> Fred, do you know of a reason why I can't stitch a newer ZODB into
>> Zope(2) trunk?  I have a dim, fading memory of the last attempt
>> failing, and of agreeing in email to wait for the "5 guys" to "do
>> something" before trying again.  Sorry for not being more specific ...

> We need to do the zpkg/ZODB switch all at once because it affects how
> extensions get their include files.

Aha!  That vaguely rings another vague bell ;-)  The ZODB 3.5+ source
code spells "#include" in its C files in a different way, and that
can't work with the way Zope trunk is currently built.

> When I tried switching the Zope 2 trunk before, there was a problem due
> to Five tests failing.  I don't remember the details, but the Five-folks
> seemed to think things would be better with newer versions of Five.
> Since Five development is done elsewhere, though, it's hard to tell what the
> deal is with that.

Can anyone working on Five comment here, please?  I gather that the
first 2.9 beta release occurs in 2 weeks, and if Fred can't do his
zpkgtools work, I can't update the trunk to a newer ZODB, and then
Chris McDonough can't do his rework of mount points (the original
topic of this thread), and then (best case) the world economy

> I snapshotted what I did get done as the zpkg-build-branch, so we can get
> back to it without duplicating work.

So there's no reason yet to be depressed ;-)
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to