Dieter Maurer wrote:
yuppie wrote at 2005-10-27 14:45 +0200:
4.) related cleanup:

Application.install_product has some backwards compatibility code for products that have initialization code outside the 'initialize' method of their This is deprecated at least for 5 years. I'd like to add explicit deprecation warnings on the 2.8 branch and to remove that code for Zope 2.9.

I hate that:

  While you might have the feeling that it were deprecated,
  'ZSQLMethods' still use part of the old style initialization
  (they have an "initialize" but still use "methods", "__ac_permissions__"
  and "__module_aliases__").

__module_aliases__ are not affected by that change. They are not initialized by Application.install_product.

Cheers, Yuppie

Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to