Could you provide details about why you think there's a leak in the code (what led you to Wrapper_findattr), and how to reproduce it consistently on a blank platform (Zope 2.8.4 preferred)?

Maybe open a bug in the collector at also.



Dan Pozmanter wrote:
Consider it reported then.
(Sorry for the delay, I was out of the office for most of last week).

It looks like the problem is in Wrapper_findattr.

Any thoughts?

Daniel Pozmanter
Siteworx, Inc.
"Festina Lente" - Gaius Julius

-----Original Message-----
From: Chris McDonough [mailto:[EMAIL PROTECTED] Sent: Monday, October 31, 2005 10:33 PM
To: Dan Pozmanter
Subject: Re: [Zope-dev] Memory Leak Question

Nobody has yet reported a memory leak symptom against any particular
piece of Zope 2.8.X yet, AFAIK.

On Oct 31, 2005, at 6:34 PM, Dan Pozmanter wrote:


I was poking around in _Acquisition.c, and noticed my memory usage spiked. Returning to the vanilla code (2.8.2-final), I noticed the same spike (just less pronounced).
(If you refresh the page a few gazillion times this pops up).

I would not categorize this as an actual bug report (I'd like to test more rigorously with a script to verify a leak), but after reading the

note on Changes for 2.8.x in the to do section, I was curious:
Is this a known issue?

If so, has there been any headway, and can I be of any assistance in resolving it?

Florent Guillaume, Nuxeo (Paris, France)   CTO, Director of R&D
+33 1 40 33 71 59   [EMAIL PROTECTED]
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to