Philipp von Weitershausen wrote:
...
Actually, I put this particular test (functional.txt) on level=2 because
it would fail when run together with other Five tests. It passes fine
when run by itself. This test exists identically in Five 1.2 (based on
Zope 2.8) where it passes just fine when run together with other tests
and by itself. During the hot phase of making the deadline on November
1st, I decided that this wasn't a big issue and could be resolved during
the beta phase (after all, the test passes by itself). I obviously
forgot to look into it again, but then again, I still don't know what
the heck is wrong with this.


Obviously, some other test isn't cleaning up after itself.

The way to debug this is by trial and error, running this test in combination
with other tests until it fails. (It would be cool, in some future version of 
the
test runner, to automate the search process.  Even a simple option to run
tests by number would probably help a lot, making a manual binary search
pretty easy.)

Jim

--
Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to