I have a site running Zope 2.9.6 which thinks it is running in debug mode.

I've tried putting debug-mode off in the zope.conf, and also leaving out the line about debug-mode completely, but neither work - the site still believes it is running in debug mode!

As far as I can see, it appears that it is using the DefaultConfiguration from App.config - certainly changing debug mode there from True to False solved the problem. However, I could not find where in the code the configuration was explicitly loaded on startup in order to verify what was going on. Any ideas where this might be? And what might be the root cause of it (it is fine on other machines that have been built using the same script).

Also, I was finding it hard to debug the problem as to get any output/use pdb, I have to start the site in debug mode anyway! Any ideas for how I can trace through the startup code much appreciated...!



Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to