Philipp von Weitershausen wrote:
[snip]
Only the '==' qualifier in setup.py is a bad idea because it locks you down. Other qualifiers are actually quite necessary sometimes.


Agreed.

In addition hopefully at some point we'll get 'or' support, so you can use == again:

zope.i18nmessageid >= 3.4.2 or zope.i18nmessageid == 3.4.2

A tool like buildout can then choose to pick the more specific version indicators if there is nothing else overriding it.

This would solve a ton of problems we're currently trying to use external indexes for (either Grok's list or KGS). Once this is in place, the only use for an external package index would be to make sure no releases are ever deleted, or changed without updating the version number.

I know I sound like a broken record on this, but fixing versions in indexes is really the wrong place: the version requirements should be in the releases themselves. Any index approach will need as many indexes as there are frameworks and applications. There just needs to be a way to override them from outer dependencies.

Regards,

Martijn

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to