On 2008-01-24 18:04:44 +0100, Stephan Richter <[EMAIL PROTECTED]> said:

On Thursday 24 January 2008, Christian Zagrodnick wrote:
the release of zope.viewlet 3.4.1 on pypi is missing the data files
(like .txt and .zcml), hence it is unusable. Also the date in the
CHANGES is wrong (2007 should be 2008)


The fact that you noticed this problem this quickly tells me you are not using
the KGS. I tend to reply to this "tough luck". I will update the KGS as soon
as I have re-released the packages. Jim has also given me already a
new "zope-dev" directory already, so we can evolve a new, experimental KGS
there.

BTW, if you want to use a newer package than the KGS provides, you can always
use the find-links option and point to the package in PyPI or PPIX directly.

Most component packages do not use the KGS in their buildout, so I wasn't either. For production use we pin exact versions actually.


Roger, it is good that you do releases, but could to please take take
of making them proper?

He did take the care. The problem is a Python bug as Martijn pointed out
later.

Yeah, actually I wondered how it would be possible to do it wrong ;)


BTW Roger, z3c.menu.simple has the same problem of missing data files.

Yes, there are a bunch of packages that have this problem. I am going to
re-release them all. (In fact, I have already started.)

Good. Thanks!


--
Christian Zagrodnick

gocept gmbh & co. kg  ·  forsterstrasse 29 · 06112 halle/saale
www.gocept.com · fon. +49 345 12298894 · fax. +49 345 12298891



_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to