On Thu, Oct 23, 2008 at 08:57:30AM +0200, Thomas Lotze wrote: > Jim Fulton wrote: > > > I would change it to just use getattr rather than hasattr. > > > > try: > > getattr(ob, name) > > except AttributeError: > > return False > > ... > > Given the controversy about our original proposal, I think I'll just > implement Jim's suggestion. I'll do so as soon as possible.
Thank you. Marius Gedminas -- Shift happens. -- Doppler
Description: Digital signature
_______________________________________________ Zope-Dev maillist - Zope-Dev@zope.org http://mail.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce http://mail.zope.org/mailman/listinfo/zope )