Martijn Faassen wrote at 2008-12-18 16:27 +0100:
> ...
>You should, and likely are, shipping your package with a recommended 
>list of versions.

Apparently, "grok" was forced to go this route.
But, in principle, this is undesirable.

Most of my components work with a wide version range of other
components. I would not like to expose a single version.
Usually, I include a narrative of the form: known to work with 2.6.x
through 2.11.x; may work with other versions as well (not tested).

In the past, I have seen excessive deprecation warnings and had
the feeling that the warning feature is overused (as many new features).

Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to