Stephan Richter wrote:
> On Thursday 09 April 2009, Martin Aspeli wrote:
>> Clearly, I'm getting too new a version of RestrictedPython, but this is
>> running against the 3.4 KGS, so I don't see how that could really happen.
> 
> This is not a problem. Ignore those errors as they happen in the Python 2.6 
> support code.Everything installed fine.
> 
> Got RestrictedPython 3.5.0.

Mmm... it doesn't let me run the tests though:

$ ./bin/test
Test-module import failures:

Module: z3c.form.browser.tests

Traceback (most recent call last):
   File 
"/users/optilude/Development/Plone/Code/Products/z3c.form/src/z3c/form/browser/tests.py",
 
line 16, in ?
     from z3c.form import testing
   File 
"/users/optilude/Development/Plone/Code/Products/z3c.form/src/z3c/form/testing.py",
 
line 28, in ?
     from zope.app.testing import setup
   File 
"/Users/optilude/.buildout/eggs/zope.app.testing-3.6.0-py2.4.egg/zope/app/testing/setup.py",
 
line 47, in ?
     from zope.container.traversal import ContainerTraversable
   File 
"/Users/optilude/.buildout/eggs/zope.container-3.8.1-py2.4-macosx-10.3-i386.egg/zope/container/traversal.py",
 
line 26, in ?
     from zope.publisher.interfaces import IDefaultViewName, NotFound
ImportError: cannot import name IDefaultViewName


Module: z3c.form.tests.test_doc

Traceback (most recent call last):
   File 
"/users/optilude/Development/Plone/Code/Products/z3c.form/src/z3c/form/tests/test_doc.py",
 
line 23, in ?
     from zope.app.testing import placelesssetup
   File 
"/Users/optilude/.buildout/eggs/zope.app.testing-3.6.0-py2.4.egg/zope/app/testing/placelesssetup.py",
 
line 26, in ?
     from zope.container.testing \
   File 
"/Users/optilude/.buildout/eggs/zope.container-3.8.1-py2.4-macosx-10.3-i386.egg/zope/container/testing.py",
 
line 29, in ?
     from zope.container.traversal import ContainerTraversable
   File 
"/Users/optilude/.buildout/eggs/zope.container-3.8.1-py2.4-macosx-10.3-i386.egg/zope/container/traversal.py",
 
line 26, in ?
     from zope.publisher.interfaces import IDefaultViewName, NotFound
ImportError: cannot import name IDefaultViewName



Test-modules with import problems:
   z3c.form.browser.tests
   z3c.form.tests.test_doc
Total: 0 tests, 0 failures, 0 errors in 0.000 seconds.
(optilude)(~/Development/Plone/Code/Products/z3c.form)
$

My working set is pretty weird too. Lots of 3.5.x and 3.6.x and even a 
3.8.x.

$ cat bin/test
#!/opt/local/Library/Frameworks/Python.framework/Versions/2.4/Resources/Python.app/Contents/MacOS/Python

import sys
sys.path[0:0] = [
   '/users/optilude/Development/Plone/Code/Products/z3c.form/src',
   '/Users/optilude/.buildout/eggs/zope.testing-3.7.1-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.interface-3.5.0-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/setuptools-0.6c9-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.i18n-3.4.4-py2.4.egg',
   '/Users/optilude/.buildout/eggs/z3c.template-1.1a1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/z3c.coverage-0.1.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.container-3.7.0-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.security-3.6.0-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/zope.schema-3.5.2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.publisher-3.5.5-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.pagetemplate-3.4.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.location-3.5.3-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.lifecycleevent-3.5.0-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.i18nmessageid-3.4.3-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/zope.i18n-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.event-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.configuration-3.4.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.component-3.5.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.testing-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.pagetemplate-3.5.0-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/ZODB3-3.9.0a12-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/zope.app.publisher-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.component-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.tal-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.copypastemove-3.5.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.dublincore-3.4.2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.traversing-3.5.2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.size-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.exceptions-3.5.2-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.container-3.8.1-py2.4-macosx-10.3-i386.egg',
 
'/Users/optilude/.buildout/eggs/zope.proxy-3.5.0-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/zope.deferredimport-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/pytz-2009a-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.deprecation-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.tales-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.copy-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.site-3.6.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.security-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.publication-3.5.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.dependable-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.debug-3.4.1-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.app.authentication-3.5.0a2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.appsetup-3.9.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.annotation-3.4.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zdaemon-2.0.2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/ZConfig-2.6.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zc.lockfile-1.0.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/transaction-1.0a1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.datetime-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.contenttype-3.4.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.formlib-3.5.2-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.filerepresentation-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.cachedescriptors-3.4.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.interface-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.broken-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.dottedname-3.4.5-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.form-3.7.1-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.browser-0.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.exception-3.4.2-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.app.applicationcontrol-3.4.3-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.http-3.5.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.error-3.6.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.session-3.8.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/RestrictedPython-3.4.3-py2.4.egg',
 
'/Users/optilude/.buildout/eggs/zope.hookable-3.4.0-py2.4-macosx-10.3-i386.egg',
   '/Users/optilude/.buildout/eggs/zodbcode-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.app.basicskin-3.4.0-py2.4.egg',
   '/Users/optilude/.buildout/eggs/zope.minmax-1.1.0-py2.4.egg',
   ]

I'd like to go fix a few things this weekend, but I don't have time to 
start unpickling these dependency issues.

Cheers,
Martin

-- 
Author of `Professional Plone Development`, a book for developers who
want to work with Plone. See http://martinaspeli.net/plone-book

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to