Hi All,

just updated one of my packages buildouts and tried to run the tests, I got:

$ bin/test
Test-module import failures:

Module: mortar.tests.test_docs

ValueError: Module-relative files may not have absolute paths

Running zope.testing.testrunner.layer.UnitTests tests:
   Set up zope.testing.testrunner.layer.UnitTests in 0.000 seconds.
   Ran 42 tests with 0 failures and 0 errors in 0.023 seconds.

To try and figure out where this rather unhelpful message (which doesn't 
occur when the same tests are run with the same versions of all eggs on 
Windows) was coming from, I tried:

$ bin/test -D
Traceback (most recent call last):
   File "bin/test", line 28, in <module>
line 95, in __init__
     raise TypeError('If post_mortem is specified, '
TypeError: If post_mortem is specified, full exc_info must be passed!

No idea what this means either... anyone?


Simplistix - Content Management, Batch Processing & Python Consulting
            - http://www.simplistix.co.uk
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to