On Tue, Dec 1, 2009 at 01:16, Gary Poster <gary.pos...@gmail.com> wrote: > I don't love "singleton." I think it is better than "utility." I agree at > least that it probably isn't better enough to introduce confusion. I'd be > more insistent on "singleton", or finding a better term than either of them, > if this were a fresh API.
I wonder if the best isn't to make the documentation clearly say "Utilties are singleton components that can be looked up per interface". -- Lennart Regebro: Python, Zope, Plone, Grok http://regebro.wordpress.com/ +33 661 58 14 64 _______________________________________________ Zope-Dev maillist - Zope-Dev@zope.org https://mail.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists - https://mail.zope.org/mailman/listinfo/zope-announce https://mail.zope.org/mailman/listinfo/zope )