On Fri, Feb 4, 2011 at 5:49 PM, Gediminas Paulauskas <mene...@pov.lt> wrote:
> But then I see that some other modules (most notably, zope.traversing
> 3.13.1) that have trunk in ztk 1.0 require zope.security[zcml]>=3.8
> but we only have 3.7.4. It looks like a harmless change, can
> zope.security be upgraded in the stable branch?
The ZTK release team discussed the issue of upgrading versions in one
of their last meetings. I haven't had time to write down a polished
policy document about this. So here's the short version:
- In general we only want bugfixes in bugfix ZTK releases (for example
ZTK 1.0.1 to 1.0.2).
- If a package has had feature update (like zope.security 3.7 to 3.8)
anyone can suggest to update to the new version.
- Such suggestion should be posted to zope-dev before checking in the
actual version update into Subversion.
- The suggestion should come with a short rationale as to why this
upgrade is considered safe and a link to the changelog (like
- You can make the change in Subversion right after posting the
suggestion, but the release team reserves itself the right to revert
it - if we don't agree with the rationale.
I hope this is clear enough and has little enough stop energy in it,
while allowing the release team to guarantee the stability of the ZTK
In case of zope.security 3.8.0 I don't see any problem upgrading to it
for ZTK 1.0.x.
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -