-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 03/21/2011 07:57 AM, Zope Tests Summarizer wrote:

> Subject: FAILED : Zope Buildbot / zope2.12-py2.6 slave-ubuntu64
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 09:44:36 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035632.html
>
> Subject: FAILED : Zope Buildbot / zope2.12-py2.6 slave-ubuntu32
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 09:44:59 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035633.html
>
> Subject: FAILED : Zope Buildbot / zope2.12-py2.6 slave-osx
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 09:46:37 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035634.html


These all fail due to something like:

 Error in test test_escape (pythongettext.tests.test_compile.TestWriter)
 Traceback (most recent call last):
   File
"/home/zope/.buildout/eggs/unittest2-0.5.1-py2.6.egg/unittest2/case.py",
line 340, in run
     testMethod()
   File
"/home/zope/.buildout/eggs/python_gettext-1.1-py2.6.egg/pythongettext/tests/test_compile.py",
line 65, in test_escape
     po_file = file(os.path.join(self.folder, 'test_escape.po'), 'rb')
 IOError: [Errno 2] No such file or directory:
'/home/zope/.buildout/eggs/python_gettext-1.1-py2.6.egg/pythongettext/tests/test_escape.po'

and a bunch more in python_gettest-1.1.  Why are we wedging in that
library version if its tests are broken?


> Subject: FAILED : Zope Buildbot / zopetoolkit-1.0_win-py2.4 slave-win
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 09:57:26 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035639.html

This is a build failure::
  Updating test-ztk.
  Getting distribution for 'setuptools==0.6c11'.

 An internal error occured due to a bug in either zc.buildout or in a
recipe being used:
 Traceback (most recent call last):
 ...
   File
"c:\users\richard\.buildout\eggs\setuptools-0.6c11-py2.4.egg\pkg_resources.py",
line 1238, in _get
 IOError: zipimport: can not open file
c:\users\richard\.buildout\eggs\setuptools-0.6c11-py2.4.egg


> Subject: FAILED : Zope Buildbot / zopetoolkit-1.1-py2.6 slave-ubuntu32
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 10:12:01 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035645.html

This one hangs without producing any informative output.


> Subject: FAILED : Zope Buildbot / zope2.14-py2.6 slave-ubuntu32
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 13:10:43 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035649.html
>
> Subject: FAILED : Zope Buildbot / zope2.14-py2.7 slave-ubuntu32
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 13:12:19 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035650.html
> 
> Subject: FAILED : Zope Buildbot / zope2.14-py2.6 slave-ubuntu64
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 15:26:33 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035661.html
> 
> Subject: FAILED : Zope Buildbot / zope2.14-py2.7 slave-ubuntu64
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 15:28:05 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035662.html


The 2.14 failures are the ones Gedminas diagnosed, due to IPv6 syntax in
the config file, not supported by ZConfig.

> Subject: FAILED : Zope Buildbot / zope2.13_win-py2.6 slave-win
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 15:41:43 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035665.html
> 
> Subject: FAILED : Zope Buildbot / zope2.13_win-py2.7 slave-win
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 15:43:55 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035666.html

These are both weird Windows build failures::

 error: Setup script exited with error: Unable to find vcvarsall.bat
 While:
   Installing test.
   Getting distribution for 'Acquisition==2.13.7'.
 Error: Couldn't install: Acquisition 2.13.7


> Subject: FAILED : winbot / zc_buildout_dev py_254_win32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 17:07:28 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035690.html
> 
> Subject: FAILED : winbot / zc_buildout_dev py_265_win32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 17:07:39 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035691.html
> 
> Subject: FAILED : winbot / zc_buildout_dev py_265_win64
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 17:07:50 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035692.html
> 
> Subject: FAILED : winbot / zc_buildout_dev py_270_win32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 17:08:00 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035693.html
> 
> Subject: FAILED : winbot / zc_buildout_dev py_270_win64
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 17:08:14 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035694.html

More weird Windows build failures::


 c:\buildslave\zc_buildout_dev_py_254_win32\build>bin\test.exe
- --exit-with-status -1"
 'bin\test.exe' is not recognized as an internal or external command,
operable program or batch file.


> Subject: FAILED : winbot / z3c.ptcompat_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 20:04:06 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035712.html
> 
> Subject: FAILED : winbot / z3c.rml_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 20:23:58 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035713.html
> 
> Subject: FAILED : winbot / z3c.form_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 20:36:50 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035714.html
> 
> Subject: FAILED : winbot / z3c.coverage_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 20:56:05 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035718.html
> 
> Subject: FAILED : winbot / z3c.macro_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 20:57:10 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035719.html
> 
> Subject: FAILED : winbot / z3c.pagelet_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 21:08:18 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035720.html
> 
> Subject: FAILED : winbot / z3c.recipe.paster_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 21:26:39 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035721.html
> 
> Subject: FAILED : winbot / z3c.template_py_265_32
> From: buildbot at winbot.zope.org
> Date: Sun Mar 20 21:28:29 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035722.html

Can we *please* either get these tests to pass, or else kill them off?
At a bare minimum, put all the 'zc3.*' tests into a single buildout and
have only one failure?

> Subject: FAILED : ZTK 1.0dev / Python2.5.5 Linux 64bit
> From: ccomb at free.fr
> Date: Sun Mar 20 23:12:07 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035728.html

This is the "makes my eyes bleed" doctest failure I'm never gonna diagnose.


> Subject: FAILED (errors=8) : Zope-2.12-alltests Python-2.6.5 : Linux
> From: Zope Tests
> Date: Mon Mar 21 02:12:48 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035735.html

More python-gettest 1.1 collateral damage.


> Subject: FAILED (errors=1) : Zope-trunk Python-2.6.5 : Linux
> From: Zope Tests
> Date: Mon Mar 21 02:18:48 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035738.html
> 
> Subject: FAILED (errors=1) : Zope-trunk-alltests Python-2.6.5 : Linux
> From: Zope Tests
> Date: Mon Mar 21 02:20:48 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035739.html

More IPv6 collateral damage.


> Subject: UNKNOWN : Zope Buildbot / zopetoolkit-1.0-py2.6 slave-ubuntu32
> From: jdriessen at thehealthagency.com
> Date: Sun Mar 20 13:51:20 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035653.html

This is some kind of weird failure in the test runner machinery:

 <class 'twisted.spread.pb.PBConnectionLost'>: [Failure instance:
Traceback (failure with no frames):
 <class 'twisted.internet.error.ConnectionDone'>: Connection was closed
cleanly. ]



Tres.
- -- 
===================================================================
Tres Seaver          +1 540-429-0999          tsea...@palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk2HdF0ACgkQ+gerLs4ltQ7izQCgqoYvCtGXzut4fxJxUNvRABs+
DxgAnAlqIxG6F0lvmDnBnC3LDTjmKFrk
=Nhy4
-----END PGP SIGNATURE-----

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to