2011/3/22 Zope Tests Summarizer <zope-te...@epy.co.at>:
> Summary of messages to the zope-tests list.
> Period Mon Mar 21 12:00:00 2011 UTC to Tue Mar 22 12:00:00 2011 UTC.

...

> Subject: FAILED : Zope Buildbot / zopetoolkit-1.0_win-py2.4 slave-win
> From: jdriessen at thehealthagency.com
> Date: Mon Mar 21 14:49:16 EDT 2011
> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035748.html

This one fails because python-gettext 1.1 tests use `with` statement
that is not available on python 2.4 or 2.5, and also depends on
unittest2 that has the same problem. This introduces a new dependency
to the stable branch, and that's not welcome... I do not think that
either the with statement or unittest2 are needed for the fixes that
you did. It may look better, but can be made compatible with old
pythons and not add a dependency.

We don't run tests for external packages and it looks like only the
tests are incompatible, so it is strange to see such failure. There is
a warning for both packages:

zip_safe flag not set; analyzing archive contents...

and then the failures. Maybe setting zip_safe would prevent
compilation of test files and installation will work on python 2.4?

Also strange is that buildbots on Linux have not complained about this.

Gediminas
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to