On Tue, Mar 22, 2011 at 4:30 PM, Gediminas Paulauskas <mene...@pov.lt> wrote:
> This one fails because python-gettext 1.1 tests use `with` statement
> that is not available on python 2.4 or 2.5, and also depends on
> unittest2 that has the same problem. This introduces a new dependency
> to the stable branch, and that's not welcome...

Right. I acted too quickly there, without taking the old Python
versions into account. I haven't touched Python 2.5 or earlier in a
long time, so I tend to forget their limitations. I reverted
python-gettext to its 1.0 release for the ZTK and pulled it in on the
Zope2 level, where we require Python 2.6+ for some time now.

> I do not think that
> either the with statement or unittest2 are needed for the fixes that
> you did. It may look better, but can be made compatible with old
> pythons and not add a dependency.

Sure. You could write the code in a different way. I'm just not
motivated to do so myself. Pull requests welcome at
https://github.com/hannosch/python-gettext ;-)

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to