Sidnei da Silva wrote:
On Thu, Nov 17, 2005 at 02:42:00PM -0600, J Cameron Cooper wrote:
| The trunk currently says in PluggableAuthService.py::
| | try:
|      from OFS.interfaces import IObjectManager
|      from OFS.interfaces import ISimpleItem
|      from OFS.interfaces import IPropertyManager
|  except ImportError: # BBB
|      from Products.Five.interfaces import IObjectManager
|      from Products.Five.interfaces import ISimpleItem
|      from Products.Five.interfaces import IPropertyManager
| | I think this is supposed to support Zope 2.7 and 2.8 interfaces. | However, I don't see any of the first three imports existing in Zope | 2.7. (Or, at least, 2.7.4.) | | I haven't tested this myself, but do have a report of it not working.


This is actually to support earlier versions of 2.8, as the interfaces
were moved from Five to Zope in 2.8.x where I'm not quite sure what .x
is.

Fair enough. But this still means it is dead on Zope 2.7. Is this intended?

                --jcc

--
"Building Websites with Plone"
http://plonebook.packtpub.com/

Enfold Systems, LLC
http://www.enfoldsystems.com

_______________________________________________
Zope-PAS mailing list
Zope-PAS@zope.org
http://mail.zope.org/mailman/listinfo/zope-pas

Reply via email to