Jim Fulton wrote:

Dominik Huber wrote:

Jim Fulton wrote:

I've updated the proposed APIs. I changed wording from "provide" to "register" as "unprovide" doesn't make sense. (This also conglicts less with existing APIs.)

I like the new wording. Do you offer the new wording within the zapi too?

I'd prefer to get rid of zapi.  Back when we used context wrappers,
there were a lot more dead chickens in our code that zapi helped
to manage.  I personally never (well almost never) use zapi anymore.

I would say that, in general, indirection is bad.  In many cases,
indirection is also good.  It should only be used when the good of
a particular indirection significantly outweighs the bad.  IMO,
the benefits of zapi don't outweight it's inherent obfuscation.

+1, but then I have to change my question. Do you reflect the new wording within zope.component too?


and deprecate the old ones eventually


Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to