Amos Latteier wrote:

In general I like the proposal, but I have a small nit:

registerSubscriptionAdapter's signature indicates that one of its arguments is "adapts", but the docstring indicates that it is named "required". The same thing is true with unregisterSubscriptionAdapter, registerHandler, and unregisterHandler.

Which is preferred, "adapts" or "required"? Adapts seems more natural to me since it echoes the name of the adapts() function, but perhaps I'm missing something that makes "required" more appropriate.

Oops. Fixed. I don't know where "adapts" came from.



Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714  
Zope Corporation
Zope3-dev mailing list

Reply via email to