On May 2, 2007, at 9:00 AM, Michael Howitz wrote:

Am 02.05.2007 um 14:43 schrieb Jim Fulton:
[...]
It is expected behavior. buildout will always prefer a develop egg that meets the given requirements.

I wanted to point out that in my case this is not true. buildout preferes the released egg if it required with a minimum version. Without this version declaration the develop egg is preferred.

Assuming that you have a checkout of the trunk zc.form, then you are mistaken. The version number in the setup.py file:

  http://svn.zope.org/zc.form/trunk/setup.py?view=auto

is 0.1dev. This is before 0.1dev-r74753 and thus doesn't satisfy the requirement zc.form>=0.1dev-r74753.

If you aren't using the trunk of zc.form, you should share what version you are using.

Jim

--
Jim Fulton                      mailto:[EMAIL PROTECTED]                Python 
Powered!
CTO                             (540) 361-1714                  
http://www.python.org
Zope Corporation        http://www.zope.com             http://www.zope.org



_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to