I'm starting to use zope3 + grok and I'm on windows environment.

I've followed the grok tutorial on a linux machine but then started my
real project on a windows machine. Then when I tried to run
'bin\zopectl fg" it just didn't work.

It complained about socket.AF_UNIX on zdaemon\zdctl.py. I went there
and surrounded with a try/except: return None.

Then it complained about os.spawnlp() wich does not work on windows. I
replaced it with subprocess.call() as python's doc suggest to and it
worked fine.

Then I had same os.spawnlp() problem with "zopectl debug", now on
zc\zope3recipes\ctl.py, again replaced for subprocess.call().

But "zopectl debug" wasn't still working, was then when I figured near
last line on my project file: parts\app\debugzope-script.py it has
split the line that adds zc.zope3recipes egg to the path. I fixed this
and now everything works fine.

I'm not sure if this is enough info to get stuff fixed, just wanted to
tell about my experiences so far.

I'm a bit surprised nobody noticed those issues so far, is windows so
unpopular in zope3 / grok developers? lol

Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to