On 5/17/05, Stephan Richter <[EMAIL PROTECTED]> wrote:
> On Tuesday 17 May 2005 14:24, Dylan Reinhardt wrote:
> > If LDAP auth for PAU exists, or if there is a howto or doc explaining
> > how to do make ldapauth or ldappas work with PAU, I would greatly
> > appreciate a shove in the right direction.
> 
> ldappas was developed for PAU, but Jim made some PAU API changes in February
> or March that probably make it fail. The fixes should be pretty shallow.

Thanks for the quick response and inspiration.

I've made some changes that allow ldappas and ldapadapter to load,
create compoents and register them, but am a bit stuck after that. 
Here's what changes I've made:

In ldapadapter/browser/configure.zcml:
Line 18: 
-  class="zope.app.utility.browser.AddRegistration"
+ class="zope.app.component.browser.utility.AddRegistration"

Line 22:
- arguments="name interface"
+ arguments="name"
+ keyword_arguments="interface"


In ldappas/configure.zcml:
Line 14 and 19
changed "zope.app.pas.interfaces" to "zope.app.authentication.interfaces"

In ldappas/authentication.py
Lines 26 & 27:
Changed "zope.app.pas.interfaces" to "zope.app.authentication.interfaces"


Those changes allow ldappas and ldapadapter to load and then I'm able
to add, configure and register my LDAP adapter and LDAP auth plugin
components.  It seems to work correctly and the adapter tests OK.

But my pluggable auth utility still can't see the ldap plugin. 

I feel like I must be pretty close here... any suggestions greatly appreciated.

Thanks,

Dylan
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to