-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Florian Lindner wrote:
> Am Dienstag, 27. September 2005 15:34 schrieb Julien Anguenot:
> 
>>Florian Lindner wrote:
>>
>>>Am Samstag, 17. September 2005 15:10 schrieb Florian Lindner:
>>>
>>>>Hello,
>>>>I've a wierd error.
>>>>
>>>>I've a configure.zcml with:
>>>>
>>>>   <addform
>>>>       schema="CS.Link.interfaces.ILink"
>>>>       name="AddCSLink.html"
>>>>       content_factory="CS.Link.link.Link"
>>>>       permission="CS.Add"
>>>>       layer="centershock"
>>>>   />
>>>>
>>>>   <addMenuItem
>>>>       title="Link"
>>>>       class="CS.Link.link.Link"
>>>>       view="AddCSLink.html"
>>>>       permission="CS.Add"
>>>>       for="CS.ContentFolder.interfaces.IContentFolder"
>>>>       menu="CSaddMenu"
>>>>   />
>>>>
>>>>But this gives a configuration error upon startup:
>>>>
>>>> File "/home/florian/Zope3/src/zope/app/publisher/browser/menumeta.py",
>>>>line 214, in _checkViewFor
>>>>   raise ConfigurationError(
>>>>zope.configuration.config.ConfigurationExecutionError:
>>>>zope.configuration.exceptions.ConfigurationError: view name
>>>>AddCSLink.html not found
>>>> in:
>>>> File
>>>>"/home/florian/Desktop/zope/lib/python/CS/Link/browser/skin/configure.zcm
>>>>l" , line 20.4-27.6
>>>>     <addMenuItem
>>>>         title="Link"
>>>>         class="CS.Link.link.Link"
>>>>         view="AddCSLink.html"
>>>>         permission="CS.Add"
>>>>         for="CS.ContentFolder.interfaces.IContentFolder"
>>>>         menu="CSaddMenu"
>>>>     />
>>>>
>>>>
>>>>I really don't understand why the view is not found...
>>>
>>>I still have this problem. Is it just to easy so that noone answers me or
>>>does really nobody knows some help?
>>>
>>>I'm really stuck with that. If somebody knows something, _please_ answer!
>>
>>Hi Florian,
>>
>>It means the view name "AddCSLink.html" is not registred for the
>>CS.ContentFolder.interfaces.IContentFolder *and* the default layer.
>>
>>It used to work before the #307 collector issue fix.
>>
>>See :
>>http://svn.zope.org/Zope3/trunk/src/zope/app/publisher/browser/menumeta.py?
>>rev=37584&view=auto
>>
>>_checkViewFor() 
> 
> 
> The arguments in _checkViewFor are:
> 
> for_ = <InterfaceClass CS.ContentFolder.interfaces.IContentFolder>
> layer = <InterfaceClass 
> zope.publisher.interfaces.browser.IDefaultBrowserLayer>
> view_name = AddCSLink.html
> 
> 
> 
>>and addMenuItem() 
> 
> 
> What information you want from addMenuItem?
> 
> 
>>Maybe a more verbose error is needed saying on which interfaces the
>>multi-adaper lookup failed ?
> 
> 
> It works when I take the for attribute out of the addMenuItem directive. 
> However I want to have this addform displayed in the menu when I have a view 
> on IContentFolder.  Without the for attribute it is not shown.
> The addform works perfectly from contentfolderobject/+/AddCSLink.html. I just 
> want to have a addMenuItem in the CSaddMenu that is shown on all views on 
> IContentFolder. All that should be placed in the centersock layer.
> 
> I hope I could express what I mean...  ;-)
> 

Try to add a layer="centershock" within your addMenuItem directive such
as :

 <addMenuItem
       title="Link"
       class="CS.Link.link.Link"
       view="AddCSLink.html"
       permission="CS.Add"
       for="CS.ContentFolder.interfaces.IContentFolder"
       menu="CSaddMenu"
       layer="centershock"
   />

        J.

- --
Julien Anguenot | Nuxeo R&D (Paris, France)
CPS Platform : http://www.cps-project.org
Zope3 / ECM   : http://www.z3lab.org
mail: anguenot at nuxeo.com; tel: +33 (0) 6 72 57 57 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFDOWHHGhoG8MxZ/pIRAmrdAJ9tmYaCMLK2BuDWvNzX/eqaVaUkQwCeKajC
gAkw8Y/FcEcmtSByPHXBAOU=
=GNIs
-----END PGP SIGNATURE-----
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to