Hi there!

I've played a bit with the Zope3 install on my OpenBSD and i've found and interesting thing. The tar (and pax) of OpenBSD has some problems
with some of the files as the extracted files have wrong file name:

... and some more ...

That 0000644 reminds me a protection mask but I haven't checked what's inside the archive.

The filename problem results in the following exception when I try to execute the make command:

/usr/local/bin/python install.py -q build
Traceback (most recent call last):
 File "install.py", line 28, in ?
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/setup.py", line 103, in initialize
   self.scan(depname, pkgdir, reldir)
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/setup.py", line 191, in scan
   self.scan_package(name, directory, reldir)
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/setup.py", line 202, in scan_package
   pkginfo = package.loadPackageInfo(name, directory, reldir)
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/package.py", line 100, in loadPackageInfo
   pkginfo = read_package_info(directory, reldir)
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/package.py", line 157, in read_package_info
   data_files[:] = expand_globs(directory, reldir, data_files)
File "/usr/home/tiz/Zope-3.1.0/Support/zpkgsetup/package.py", line 294, in expand_globs
   raise ValueError(
ValueError: filename pattern '*-configure.zcml' doesn't match any files
*** Error code 1

Stop in /home/tiz/Zope-3.1.0 (line 18 of Makefile).


- OpenBSD 3.7, regular user without root privileges
- the md5 of the archive matches to the one published on zope.org
- tried tar and pax included with the operating system, both did it wrong

I unpacked the very same archive on my Windows machine with Total Commander built-in unpacker and it worked well, no nasty filename modifications and make ran without errors. :)


ps: is there a bug tracker or a bug mail list i can send messages like this?
Zope3-users mailing list

Reply via email to