when I use formlib the traditional way (registering the page via ZCML, going 
to it via the ZMI),
  everything works fine. The problem is I can't access it programatically. The 
thing I try to do
  is : 
  - call a method via JSON RPC (by the way jsonserver is great ;-)) 
  - in this method I get my object (through sqlos, which is nice too ;-)) and 
then call the formlib class to render my page in html
  - send back the html which is used to update  my page.
  Has anyone tried to use formlib this way, I really need to use AJAX and it 
seems that I can't have both working together, 
  I must be missing something.

----- Message d'origine ----
De : Stéphane Brault <[EMAIL PROTECTED]>
À : zope3-users@zope.org
Envoyé le : Mardi, 18 Avril 2006, 4h16mn 55s
Objet : Re : [Zope3-Users] formlib problem

Thanks Michael,
 There is indeed something missing :
 ComponentLookupError: ((
  zope.schema._bootstrapfields.Int object at 0x01A83610 , 
  zope.publisher.browser.TestRequest instance URL= ), 
  InterfaceClass zope.app.form.interfaces.IDisplayWidget , u'')
 My problem has nothing to do with containers, since my interface is
 not a container. It seems that zope can't find the adapters for the shema 
fields, even when 
 I register them by code. I really don't know what to do from now.
 The fact is I use AJAX, so I don't need to register my views, I just
 call them from code to use the generated html as a response to a
 javascript call that then update my page.

----- Message d'origine ----
De : Michael Howitz <[EMAIL PROTECTED]>
À : Stéphane Brault <[EMAIL PROTECTED]>
Cc : user-list zope <zope3-users@zope.org>
Envoyé le : Mardi, 18 Avril 2006, 3h40mn 16s
Objet : Re: [Zope3-Users] formlib problem

Stéphane Brault wrote:
> Hi,
>  I can't use formlib, when I run the example in the form.txt I get this error:
>  Traceback (most recent call last):
>    File "<pyshell#29>", line 1, in -toplevel-
>      print MyForm(None, request)()
>    File "<pyshell#26>", line 6, in __call__
>      widgets = form.setUpWidgets(self.form_fields, 'form', self.context, 
> self.request, ignore_request= ignore_request)
>    File "C:\Python24\Lib\site-packages\zope\formlib\form.py", line 255, in 
> setUpWidgets
>      IInputWidget)
>    File "C:\Python24\Lib\site-packages\zope\component\__init__.py", line 154, 
> in getMultiAdapter
>      raise ComponentLookupError(objects, interface, name)
>  ComponentLookupError: ((,>), , u'')

There seems to be something missing before ", http..." ... did you copy 
it form the browser output?

>  It happens when setUpWidgets is called in the first example, do I need to 
> import something or to configure a component for formlib to work ?
>  Any hint ?

Guess out of the dust: does the interface of the object you want to 
display have a zope.app.container.constraints.containers directive?

This thread seems similar to your problem.


Zope3-users mailing list

Zope3-users mailing list

Reply via email to