I have been struggling to build Zope 3.2.1 on Solaris 10
but so far am not having any luck.  I read on the Zope
site "Zope 3 requires that Python 2.4.2 or newer".
I have successfully downloaded and installed the latest
Python 2.4.3.

I tried ./configure and got

Configuring Zope installation

Testing for an acceptable Python interpreter...

Python version 2.4.3 found at /usr/sfw/bin/python
Python version 2.4.3 found at /usr/sfw/bin/python2.4

No suitable Python version found. You should install
Python version 2.4.2 before continuing. Versions
2.4.1 also work, but not as optimally.

I tried with the python switch
./configure --with-python /usr/sfw/bin/python
and there were no errors but when I tried to make it

bash-3.00# gmake
/usr/sfw/bin/python install.py -q build
Traceback (most recent call last):
  File "install.py", line 28, in ?
File "/src/Zope-3.2.1/Support/zpkgsetup/setup.py", line 121, in initialize
    self.scan(depname, pkgdir, reldir)
  File "/src/Zope-3.2.1/Support/zpkgsetup/setup.py", line 211, in scan
    self.scan_package(name, directory, reldir)
File "/src/Zope-3.2.1/Support/zpkgsetup/setup.py", line 245, in scan_package
File "/src/Zope-3.2.1/Support/zpkgsetup/setup.py", line 225, in scan_package
    pkginfo = package.loadPackageInfo(name, directory, reldir)
File "/src/Zope-3.2.1/Support/zpkgsetup/package.py", line 101, in loadPackageInfo
    pkginfo = read_package_info(directory, reldir)
File "/src/Zope-3.2.1/Support/zpkgsetup/package.py", line 166, in read_package_info
    data_files[:] = expand_globs(directory, reldir, data_files)
File "/src/Zope-3.2.1/Support/zpkgsetup/package.py", line 303, in expand_globs
    raise ValueError(
ValueError: filename pattern '*-configure.zcml' doesn't match any files
gmake: *** [build] Error 1

I saw one thread "Can't build Zope on OS X" where the poster had a
similar problem but no solution was offered there.  Has anyone built
Zope 3.2.1 on Solaris 10 or can anyone offer a suggested solution?
I don't fully understand the code but I guess it is searching for
files that match *-configure.zcml and I see that such files do
exist in various places in the project tree.

Damon Register
Zope3-users mailing list

Reply via email to