hi there,

just played around a bit. so fyoi:

for ssl you need pyopenssl, as stated.
then make shure when you call you don't miss the 's':


for sftp you need pycrypto, as written in the zope.conf.
for my 3.3 trunk version (which dated beginning of may '06),
I had to uncomment the things inside these files:


but it seems that it is rather buggy for my part...

is there someone who knows the status of sftp implementation?
I also have troubles with webdav, what is the status there?



Am 17.06.2006 um 01:02 schrieb David Pratt:

I've had no problems on any platforms but you must be using the twisted server which is default in any case.


Andreas Reuleaux wrote:
I just read Davids answer - interesting - and I am a bit confused: So HTTPS seems to be working now, supported and enabled? - Is this the
official status for SSL now? Or is it just working on Mac OS X, is
pyopenssl officially required - if so, then I think this should be
stated somewhere in the release notes.
I must admit it has been a while that I tried HTTPS (with no succes at
that time) and the "(disabled for now because of error handling
problems)" that I found in the release notes was just the explanation
I found convincing at that time.
On Fri, Jun 16, 2006 at 06:53:02PM -0300, David Pratt wrote:
Hi Mike. Can you confirm you have pyopenssl-0.6 installed and proper paths in your config. It should look like this in your config if you are using the default files supplied.

   type HTTPS
   address 8443
   privatekeypath $CONFDIR/server.pem
   certificatepath $CONFDIR/server.pem

Just to let you know I am running on mac and everything is fine for me. I am on OSX 10.3.


Mike Emerick wrote:

I have been trying to get the SSL server and the SSH server running with Zope 3. When I uncomment ssh server in the zope.conf file I get the following.

Traceback (most recent call last):
 File "./runzope", line 48, in ?
 File "./runzope", line 44, in run
   main(["-C", CONFIG_FILE] + sys.argv[1:])
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/ main.py", line 74, in main
   service = setup(load_options(args))
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/ main.py", line 151, in setup
   service = server.create(db)
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/ server.py", line 204, in create
   servertype = zapi.getUtility(IServerType, self.type)
File "/usr/local/Zope-3.2.1/lib/python/zope/component/ __init__.py", line 257, in getUtility
   raise ComponentLookupError(interface, name)
zope.component.interfaces.ComponentLookupError: (<InterfaceClass zope.app.twisted.interfaces.IServerType>, 'SFTP')

I have looked every all over for a solution. I can confirm this on Suse Linux 10 and Mac OS 10.4 and 10.3. Has anyone seen this. SSL gives a similar error just replace the SFTP with SSL.

Zope3-users mailing list

Telefon: +41 44 586 68 86
Skype: perse.engineering

Zope3-users mailing list

Reply via email to