zc.recipe.egg was released 2 days ago. Now, when trying to re-run a buildout that was done before the z.r.e release, I get a VersionConflict:


[EMAIL PROTECTED] share-it]$ bin/buildout
Develop: '/srv/share-it/quills.remoteblogging'
Develop: '/srv/share-it/quills.core'
Develop: '/srv/share-it/quills.app'
Develop: '/srv/share-it/plone.marquis'
Uninstalling zopepy.
  Uninstalling zopepy.
  Loading recipe 'zc.recipe.egg==1.0.0b6'.

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:

(zc.recipe.egg 1.0.0 (/srv/share-it/eggs/zc.recipe.egg-1.0.0-py2.4.egg), Requirement.parse('zc.recipe.egg==1.0.0b6'))


I tried to remove the zopepy from the buildout, but it still tried to uninstall it and I get the error above. I also tried 'bin/buildout -n' to not get the new egg, but no luck.

I can post my buildout.cfg if it is necessary to debug the problem - i.e., other people in a similar situation aren't having the same problem. I've pinned all my recipes, so I guess the problem might be there - but I thought this is exactly the kind of problem that pinning is supposed to solve. :(



Zope3-users mailing list

Reply via email to