Did zopepy previously specify "zc.recipe.egg ==1.0.0b6" as it's recipe?

Does zopepy have an uninstall recipe? I'd be interested in seeing your existing .installed.cfg and buildout.cfg. You can send them to me privately. No need to inflict it on everybody else. :)

To work around this, I suggest adding:

  versions = versions

to your buildout section and adding the section:

  [versions]
  zc.recipe.egg = 1.0.0b6

This will force the buiodout to use 1.0.0b6 of zc.recipe.egg.

Jim

On Nov 5, 2007, at 11:24 AM, Derek Richardson wrote:

zc.recipe.egg was released 2 days ago. Now, when trying to re-run a buildout that was done before the z.r.e release, I get a VersionConflict:

#####

[EMAIL PROTECTED] share-it]$ bin/buildout
Develop: '/srv/share-it/quills.remoteblogging'
Develop: '/srv/share-it/quills.core'
Develop: '/srv/share-it/quills.app'
Develop: '/srv/share-it/plone.marquis'
Uninstalling zopepy.
While:
  Installing.
  Uninstalling zopepy.
  Loading recipe 'zc.recipe.egg==1.0.0b6'.

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:

VersionConflict:
(zc.recipe.egg 1.0.0 (/srv/share-it/eggs/zc.recipe.egg-1.0.0- py2.4.egg), Requirement.parse('zc.recipe.egg==1.0.0b6'))

#####

I tried to remove the zopepy from the buildout, but it still tried to uninstall it and I get the error above. I also tried 'bin/ buildout -n' to not get the new egg, but no luck.

I can post my buildout.cfg if it is necessary to debug the problem - i.e., other people in a similar situation aren't having the same problem. I've pinned all my recipes, so I guess the problem might be there - but I thought this is exactly the kind of problem that pinning is supposed to solve. :(

Thanks!

Derek

_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

--
Jim Fulton
Zope Corporation


_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to